Announcement

Collapse
No announcement yet.

Debian screen resolution

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Debian screen resolution

    To set (or reset) at proper screen resolution Debian (i had the situation where the only resolution available was 680 * 480), it is necessary to reconfigure the xorg.conf file, that you can find on /etc/X11/ directory.
    To do that, there are 2 ways: one manually editing the file, and one by using the shell command line. The second more easy and speedy way is:

    Open a terminal root.
    run the following command: dpkg-reconfigure -phight xserver-xorg
    The xserver-xorg window for a new configuration of screen values will be open. Move with arrows up and down and select by clicking space your needed values. I have choose for example to leave setted (and available to the system) 1024*768 and 1280*960).
    Automatically xorg.conf file will be updated and you can see your new values inside his code lines like:

    Depth 1
    Modes "1280x960" "1024x768"
    etc etc ...

    Launch the Gnome Control Center and choose Screen Resolution. New values are now availables for the screen to be selected.

  • #2
    Thank You!!!

    I cannot tell you how many other 'fixes' I tried before I found this - now my Debian install (on my ancient laptop) is running at a resolution I can live with. Thank you!!!

    Comment


    • #3
      Debian screen resolution

      Originally posted by axew3 View Post
      To set (or reset) at proper screen resolution Debian (i had the situation where the only resolution available was 680 * 480), it is necessary to reconfigure the xorg.conf file, that you can find on /etc/X11/ directory.
      To do that, there are 2 ways: one manually editing the file, and one by using the shell command line. The second more easy and speedy way is:

      Open a terminal root.
      run the following command: dpkg-reconfigure -phight xserver-xorg
      The xserver-xorg window for a new configuration of screen values will be open. Move with arrows up and down and select by clicking space your needed values. I have choose for example to leave setted (and available to the system) 1024*768 and 1280*960).
      Automatically xorg.conf file will be updated and you can see your new values inside his code lines like:

      Depth 1
      Modes "1280x960" "1024x768"
      etc etc ...

      Launch the Gnome Control Center and choose Screen Resolution. New values are now availables for the screen to be selected.
      ~~~~~~~~~~~~~~~~~~~

      Note that this answer was googled up and that the information listing *phight* xserver-xorg is only partially correct The word in the command should have been
      *phigh* without a t on the end. However, it did the trick. It was set to 1024 X 768 OK but was also set to 75Hz which I had to change to 60Hz.
      Thank you for your input.
      Little Al

      Comment


      • #4
        Terminal command not found

        I have this problem (640x480 resolution only)
        I am new to Debian, I have Ubuntu on my other computer.
        problem is...
        I type in terminal...
        dpkg-reconfigure -phigh xserver-xorg
        response is...
        bash: dpkg-reconfigure: command not found.
        If I type sudo first I get the response..
        chris is not in the sudoers file.
        I am the only user and have set the password for root myself.
        Any offers please?
        Chris

        Comment


        • #5
          hello Chris, sorry for delay in answer, have you try to edit directly the file so?
          about sudo command i had read this article that was very helpful to me (and hope also to you):
          Using sudo

          Comment


          • #6
            xorg.conf file content

            ps - chris the file /etc/X11/xorg.conf should contain the follow (if you try to edit it directly):
            Code:
            Depth 1
            Modes "1280x960" "1024x768"
            when you open the xorg.conf file you should understand where to add values

            Comment


            • #7
              I have sorted the "Sudo" bit.
              typed in termonal...
              dpkg-reconfigure -phight xserver-xorg
              This executed OK without error messages but still no options for resolution.
              My xorg file is shown below
              ......................... ......................... ......................... ......................... ...................
              # xorg.conf (X.Org X Window System server configuration file)
              #
              # This file was generated by dexconf, the Debian X Configuration tool, using
              # values from the debconf database.
              #
              # Edit this file with caution, and see the xorg.conf manual page.
              # (Type "man xorg.conf" at the shell prompt.)
              #
              # This file is automatically updated on xserver-xorg package upgrades *only*
              # if it has not been modified since the last upgrade of the xserver-xorg
              # package.
              #
              # If you have edited this file but would like it to be automatically updated
              # again, run the following command:
              # sudo dpkg-reconfigure -phigh xserver-xorg

              Section "InputDevice"
              Identifier "Generic Keyboard"
              Driver "kbd"
              Option "XkbRules" "xorg"
              Option "XkbModel" "pc105"
              Option "XkbLayout" "gb"
              EndSection

              Section "InputDevice"
              Identifier "Configured Mouse"
              Driver "mouse"
              EndSection

              Section "Device"
              Identifier "Configured Video Device"
              EndSection

              Section "Monitor"
              Identifier "Configured Monitor"
              EndSection

              Section "Screen"
              Identifier "Default Screen"
              Monitor "Configured Monitor"
              EndSection
              ......................... ......................... ......................... ......................... ......................... ................
              I am not sure what to type or exactly where to type it.
              My laptop is a Toshiba Satellite 4080CDT about 10yrs old.
              The only resolution I need is 1024x768.
              Chris

              Comment


              • #8
                Screen Modes xorg.conf

                change the screen section in your xorg.conf with this:
                Code:
                Section "Screen"
                Identifier "Default Screen"
                Monitor "Configured Monitor"
                Modes "1024x768"
                EndSection
                or more in particular, you need to change some value with yours in this case, if the above still not work:

                Code:
                Section "Screen"
                Identifier "Default Screen"
                Monitor "Configured Monitor"
                EndSection
                Section "Screen"
                    Identifier    "Default Screen"
                    Device        "NVIDIA Corporation NV34 [GeForce FX 5200]"
                    Monitor        "CS652AS"
                    DefaultDepth    16
                    SubSection "Display":
                        Depth        16
                        Modes "1280x960" "1024x768
                    EndSubSection
                EndSection
                the line Modes "1280x960" "1024x768" should work, so you should now have this two resolutions available in:
                Ubuntu Menu: System -> Preference -> Display
                If there aren't, and you're still in problem, here some solutions:
                Ubuntu x config

                Comment

                Previously entered content was automatically saved. Restore or Discard.
                Auto-Saved
                x
                Insert: Thumbnail Small Medium Large Fullsize Remove  
                x
                x
                Working...
                X